Friday, 8 March 2013

PSE Organizer is not launching (Windows)

This issue can appear in various manifestations like-
- Elements Organizer splash screen freezes at launch.
- Elements Organizer splash screen appears and then goes away.
- Nothing happens on clicking 'Organizer' tab in welcome screen.
- Organizer/Editor launches fine but hangs just after launch.

The issue mentioned can be encountered on both Win and Mac. There can be multiple reasons for this issue. Depending upon the problem, there can be various ways of resolving it. Please follow these solutions in order they are mentioned until your problem is resolved.
This is a Windows only solution. If you are facing the same issue on Mac, click here.
Note: The steps mentioned below demonstrates PSE11 but the steps are generic in nature and are valid to all PSE versions (just change the version number wherever required).

Solution 1: 

1. Rename Organizer preferences (psa.prf to say psa_old.prf) file and 'status.dat' (to say status_old.dat) file located at: %AppData%\Adobe\Elements Organizer\11.0\Organizer as shown below:

2. Navigate to 'PhotoshopElementsOrganizer.exe' located inside:
    Win x64: C:\Program Files (x86)\Adobe\Elements 11 Organizer
    Win x32: C:\Program Files\Adobe\Elements 11 Organizer
Right click 'PhotoshopElementsOrganizer.exe' and select 'Run as Admin'.
After this Windows UAC (User account control) prompt may appear, click on 'yes' button.

3. After doing this very quickly,  keep on holding 'Shift' key. After some time catalog manager dialog will appear as shown below-

4. Click on 'New' button (as shown in above dialog) and create another catalog as shown below: 
By doing this hopefully Organizer will be able to start itself. 
Now by all means, you might be working on some other catalog (lets say it is 'BigCatalog' in my case). Also as Organizer wasn't launching previously it may also be possible that the catalog may be corrupt. 
5. To re-use the catalog, Please perform 'Repair/Optimize' operations on your catalog. Detailed steps are present at here under 'Repair/Optimize your catalog' section <solution #2>.
6. Select 'BigCatalog' catalog and click on 'Open'. Now hopefully your catalog should work fine. 


Solution 2:

1. Right click 'PhotoshopElementsOrganizer.exe' (path mentioned in step #2 of  Solution #1) and select 'Properties' and click on  'Compatibility' tab. 
2. Under 'Compatibility mode pane', click on check box for 'Run this program in compatibility mode for' and select 'Windows XP (Service Pack 3) from drop down.
3. Under 'Privilege level' pane, click on check box for 'Run this Program as as Administrator' as shown in following dialog:
Note: After doing this, if Windows UAC may be prompted (while launching Elements Organizer,) click on 'Yes' button.


Solution 3:

If the above mentioned steps doesn't resolve your issue then you need to do 'Clean uninstall followed by Installing PSE with Admin rights' <coming soon>.


Please leave your comments if you have any queries. I will get back to you as soon as possible. Any feedback on improving the quality/content of the blog is highly appreciated.

Cheers !!






No comments:

Post a Comment