Wednesday, 3 April 2013

PSE Editor is not launching (Mac).

This issue can appear in various manifestations like-
- Elements Editor splash screen freezes at launch.
- Elements Editor splash screen appears and then goes away.
- Nothing happens on clicking 'Editor' tab in welcome screen.
- Organizer/Editor launches fine but hangs just after launch.
The issue mentioned can be encountered on both Win and Mac. There can be multiple reasons for this issue. Depending upon the problem, there can be various ways of resolving it. Please follow these solutions in order they are mentioned until your problem is resolved.
This is Mac only solution. If you are facing the same issue on Win, click here.
Note: The steps mentioned below demonstrates PSE11 but the steps are generic in nature and are valid to all PSE versions (just change the version number wherever required).


Solution 1:

1. Navigate to 'Go->Applications/Adobe Photoshop Elements 11->Support Files->Adobe Photoshop Elements Editor' (as shown in following snapshot). Double click 'Photoshop Elements Editor'.

2. Just after this keep on pressing Command+Option+Shift on Mac. You will get following dialog:
Click on 'Yes' button of above dialog. Hopefully Editor should launch.



Solution #2: Twain plug-in issue

Sometimes the issue can be Twain plugin. To fix this please follow:

1. Navigate to Twain folder location as shown in following snapshot: 

Please note that location of Twain plug-in is depended on PSE version and OS you are using. Please refer to this blog for detailed notes on location: http://helpx.stage.adobe.com/photoshop-elements/kb/twain-installed-photoshop-elements-11.html
2. Remove this plugin and copy it to somewhere else (say on Desktop). Now try to launch Editor (using Run as admin as mentioned in solution #2 of Editor section).  Probably it will resolve the crash. If you don't use Twain plugin (required for scanning purposed in PSE), then you are good to go. 
3. If you use PSE for scanning, copy the twain plugin from '/Applications/Adobe Photoshop Elements 11/Support Files/Optional Plug-Ins' and paste it to '/Applications/Adobe Photoshop Elements 11/Support Files/Plug-Ins'. Launch Editor while deleting its preferences (follow solution #1 of Editor section). If Editor works fine, its good else you need to re-install scanner driver (came with scanner).

Solution 3:

In case any network printer is attached try to launch without network or printer uninstall or make different printer as default.


Solution 4: 

Try launching with anti-virus off or removing PSE from conflicting list.




Please leave your comments if you have any queries. I will get back to you as soon as possible. Any feedback on improving the quality/content of the blog is highly appreciated.

Cheers !!




No comments:

Post a Comment