Thursday, 11 September 2014

How to correct hourglass (generic) thumbnail in Elements Organizer??

In Elements Organizer, when you import media, after sometime the media thumbnails appear correctly. The time lag between importing media and getting thumbnails generated varies depending upon - number of media, file size, file resolution, file location (whether on internal drive or CD/DVD or on network).
But sometimes even after leaving Organizer idle for sometime, Organizer keeps on showing generic thumbnails. There can be two possibilities here:

  • The thumbnails are not available for those particular media (like audio, some video formats or image with higher resolution).
  • There appears to be some issue with thumbnail database in Organizer.

For first case, we can't do anything but if this is the second case (say for a JPEG of 2 MB having resolution 1024x768 thumbnail is not shown) then there is a workaround to resolve this. Please try following steps:

1. In Elements Organizer, click on 'Help->System Info'. Under 'Current Catalog', the catalog location is mentioned adjacent to 'Catalog Location' field as shown below:

2. Quit Organizer. In the catalog folder, you will see a file named 'thumb.5.cache' as shown below:

Rename 'thumb.5.cache' to say 'thumb.5_old.cache'. Relaunch Organizer.

Now Organizer will start generating thumbnails for all the media in your catalog. This process will take time so please be patient. Once Organizer is finished generating thumbnails, your issue (showing generic thumbnails for some media) will be resolved. 
Please comment if your issue is not resolved.